A fix has been implemented and we are monitoring the results.
Posted Apr 15, 2026 - 19:44 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 15, 2026 - 19:21 UTC
Update
We are continuing to investigate this issue.
Posted Apr 15, 2026 - 19:20 UTC
Investigating
Some users may experience slower than normal response times or occasional timeouts. We've identified a resource issue in one of our backend services and are deploying a fix. Your data is safe, and no action is needed on your end. We apologize for the inconvenience.
Posted Apr 15, 2026 - 18:45 UTC
This incident affected: Web application, iOS app, and Android app.