Verification is currently underway for the maintenance items.
Posted Jun 27, 2026 - 14:55 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 27, 2026 - 14:00 UTC
Scheduled
Ledger synchronization and some related ledger functionality will be temporarily unavailable for a subset of businesses during scheduled maintenance. All other Docyt services remain available. Affected ledger data will sync automatically once maintenance completes.
Posted Jun 26, 2026 - 08:13 UTC
This scheduled maintenance affected: Web application.